The minimum requirements for Xcode and macOS are stipulated on the download page.

  • embedXcode and embedXcode+ require Xcode 8 on OS X 10.11 or 10.12.
  • The Legacy 7 versions require Xcode 7 on OS X 10.10 or 10.11.
  • The Legacy 6 versions require Xcode 6 on OS X 10.9 or 10.10.
  • The Legacy 5 versions require Xcode 5 on OS X 10.8 or 10.9.
  • The Legacy 4 versions require Xcode 4 on OS X 10.7 or 10.8.


Please note the Legacy versions are no longer supported.


For the boards and IDEs, please refer to the Supported Boards and IDEs page.


More information is provided in the page Requirements, License and Disclaimer.